Traktor Mod - Vorstellung und Bitte um Hilfe

  • Vielen Dank erstmal. bin schon ein Stück weiter... (noch in Blender) Habe jetzt einen aufgeteilten Traktor alles ganz gut soweit.

    Was die Dirt / Wear und AO Map angeht - Macht Ihr eine einzige Map für den ganzen Traktor oder eine Map für jedes Einzelteil?

    Im Spiel sind die Traktoren ja "einteilig" (merged Mesh), im Mod habe ich aber mehrere (Chassis, Hydraulik, Interieur und Karosserie). Da würde ich jetzt jeweils eine Map für jedes Teil erstellen oder? Die vom Chassis könnte ich auch einfach vom Serienfahrzeug übernehmen(?)

    Die XML würde ich weiter vom Serientraktor nehmen - geht das wenn meine Version weniger Funktionen hat als Serie z.B. Scheinwerfer oder Wechsel der Fahrtrichtung (Drehsitz) - kann ich dann einfach in der XML die Zeilen löschen (oder ein # davor setzen)?

    Wenn ich ein Bauteil lösche aber die XML so lasse ... gibt es einen Absturz....

    Das Interieur nehme ich erstmal so wie es ist, wenn das funktioniert mache ich mein eigenes rein, dauert aber noch...

  • Würde mich was Texturen angeht, am Standard orientieren: eine Für die gesamte Karosse, eine für Interieur und eine für Decals

    ...official coffee-to-xml converter...

    ...complaining about other people's log-files since FS13...

    specialized in: textures, ingaming, animations, tutorials and things nobody ever thought about

  • Ok. das bedeutet, die Textur für das gesamte Fahrzeug (Vehicle mat) berechne ich in Blender auf das ganze Modell. Dann verwende ich die gleiche Textur für alle Karosserie-Teile, oder? D.h. z.B. auf dem Chassis liegt die gleiche Tex wir auf der Karosse, aber die Grünen Teile liegen außerhalb der Chassisgeometrie. Umgekehrt für die (grünen) Teile der Karosse.

    Dann mache ich mal in Blender eine Merged Version für die Karosse und das Interieur damit ich das besser texturieren kann..


    Noch eine Frage, ich hoffe ich gehe Euch nicht auf die Nerven... Was die Poligonzahl angeht...

    Das Modell hat viele Runde Flächen. Die Blender-Version habe ich mit Subdivision 2 exportiert. Dann sieht man im Spiel allerdings "Kacheln".

    Ich habe es auch mal mit der Alias Version (Nurbs Surfaces) probiert. Die Tessilierung ist viel feiner, im Spiel perfekt rund. Allerdings gibt es natürlich deutlich mehr Polys. Komischerweise scheint das im Spiel nichts auszumachen, es läuft ganz normal, auch auf einer Inter 6200 onboard Grafik.

    Leider kann ich die Nurbs Version in Blender nicht richtig texturieren, das UV Mapping funktioniert nicht richtig wo die einzelnen Patches der Nurbs zusammenstoßen.

    Deswegen habe ich die Blender Version...

    Gibt es eine empfohlen max. Poligonzahl?

    Edit durch HoFFi:
    Doppelpost zusammengefasst. Bitte die Bearbeiten Funktion - unten rechts im Beitragsfenster zu finden - nutzen, wenn noch keine Antwort auf den letzten Beitrag erstellt wurde.

    Zum Verständnis, wo man diese findet hier ein Bild, die Buttons erscheinen wenn man mit der Maus in diesen Bereich fährt.

    Edited 2 times, last by da-hoffi: Ein Beitrag von B_6789 mit diesem Beitrag zusammengefügt. (May 5, 2021 at 10:36 AM).

  • Eine einzelne Textur legst Du ja beim Fahrzeug nicht drauf - sondern ein Material, welches Du mit dem Vehicleshader ansprichst. Die unterschiedlichen Bauteile legst Du dann im UV Editor auf die einzelnen Texturbereiche - entweder auf die fest definierten oder auf die vorhandenen, 8 definierbaren Farb-Material-Slots. Lediglich der Bereich für Dirt/Wear/AO ist in einer farbkodierten "Textur"-Datei...

    Wegen der runden Flächen, welche Du als Kacheln siehst - müsste man mal schauen, wieviel Faces da dein Modell an der Stelle hat. Eigentlich kann man das mittels Smoothing im Blender in Grenzen halten. Müsste man mal was an Details sehen, wo sich das bei Dir zeigt. Polys ist immer eine Sache - man kann da aber keine allg. Aussage treffen.

  • Guten Morgen zusammen,

    Vielen Dank erstmal. Das Mit dem Material / vs Textur ist doch etwas anders als z.B. in VRED...

    was die Polizahl angeht werde ich mal ausprobieren wie weit ich da gehen kann

    Ein neues Problem...

    Mit dem Mod vom Mod funktioniert das Ganze schon mal halbwegs. Ich wollte nun aber einen neuen Mod - frisch aus dem Spiel machen damit ich die Ganzen Zusatzfunktionen vom gemoddeten Traktor nicht mit drin habe, ausserdem gibt es dann keinen Ärger mit Rechten usw.

    Mit der Funktion "new Mod from Game" habe ich das dann mal ausprobiert.

    Dabei gibt es 2 Probleme:

    - ich finde in der Liste zwar alle möglichen Traktoren aus dem Spiel, aber leider nicht den Fendt 900 den ich brauche.... weiß jemand warum der nicht drin ist? der 1000, 300,500 etc - sind alle drin (komische Sache)

    Nun hatte ich überlegt einfach den 1000 zu nehmen, aber der große Nachteil .... ich muß die Karosserie in Blender nochmal anpassen und den Traktor neu aufteilen, beim 900 hatte ich das schon gemacht

    Trotzdem, ich habe es einfach mal versucht.

    Der Editor macht auch einen Ordner Fendt 1000 und legt darin 2 Files ab. was aber fehlt ist die Fendt900xml. Außerdem scheinen in der ModDesc ein paar Zeilen am Anfang zu fehlen, verglichen mit der ModEsc vom gemoddeten 900er.

    Das Resultat ist, der neue Mod 1000 erscheint nicht im Spiel....

    Dann hatte ich mal nach den Dateien für den Fendt 900 im Spiel gesucht - und gefunden. Die kann ich auch in den editor laden, aber leider ist da gar keine xml dabei. Das scheint irgendwie mit allen anderen Fendt Modellen im Spiel kombiniert zu sein oder so.

    Die Frage ist, wie kann ich aus dem Fendt 900 im Spiel einen neuen Mod erstellen bei dem alle Scripts vom Serienmodell übernommen werden?

    Ich möchte ja bei meinem Mod (im Moment) keine Zusatzfunktionen einbauen, es reicht ja erstmal das was im Serienmodell drin ist.

    Gibt es irgendeine Art Template - XML oder ModDesc?

  • Also das Fendt 900 Modell sollte in der Liste auch zu finden sein. Da ich mit der Sortierung bei "new mod from game" auch nicht immer klar komme, mache ich es mir da einfacher...

    Gehe einfach mittels Windows Explorer in das Verzeichnis, wo Dein Spiel installiert wurde (also nicht, wo deine Mods/Savegames liegen). Im Hauptverzeichnis gibt es ein Verzeichnis "data" und wenn Du dich da weiter durchhangelst, findest Du die Unterverzeichnisse data\vehicles\fendt\fendt900. Das Verzeichnis Fendt900 einfach komplett kopieren - dann hast Du alle Dateien, welche dazugehören - so auch eine fendt900.i3d, die zugehörige fendt900.i3d.shapes Datei und die fendt900.xml.

    Die Dateien kopierst in ein eigenes Verzeichnis (ausserhalb der Spielinstallation), wo Du den Mod bearbeiten willst.

    Jetzt brauchts noch einen Texteditor - mit dem musst Du ein paar Infos ändern.

    Öffne die in deinem Verzeichnis liegende fendt900.xml und ändere die Zeilen 15 und 32 so ab, dass nur noch der Dateiname ohne Verzeichnisse drin steht - also z. Bsp.

    von

    <image>data/vehicles/fendt/fendt900/store_fendt900.png</image>

    nach

    <image>store_fendt900.png</image>

    Hab jetzt in der Datei fendt900.xml sonst keine relativen Verzeichnisangaben gesehen - die mit "$data" beginnen, können so bleiben, denn die verweisen auf die Spielinstallation.

    Öffne die fendt.i3d ebenfalls mit dem Texteditor. Dort findest Du in den Zeilen 6-48 ebenfalls Referenzen zu Dateien mit Pfadangabe. Die Zeilen, welche mit "../" anfangen musst Du anpassen. "../" bedeutet immer "ein Verzeichnis zurück, demzufolge "../../" zwei, bzw. "../../../" 3 Verzeichnisse zurück. Da der Originaltraktor ja im Verzeichnis "data\vehicles\fendt\fendt900" lag, ersetzt Du nun die relativen Angaben durch direkte Angabe auf das Verzeichnis der Spielinstallation. Das zeigt sich daran, dass die Zeile immer mit "$data" beginnt.

    Ich hoffe, das war verständlich. Nachdem du die Änderungen in der XML und der i3d gespeichert hast, kannst Du nun mit dem GE etc. dein Modell weiterbearbeiten...

  • Vielen Dank, das ist eine gute Anleitung - das hatte ich gesucht. Ich habe leider von XML usw. überhaupt keine Ahnung...

    Ich habe das jetzt kopiert und geändert - mal sehen wie es funktioniert (mit dem unveränderten Traktor erst mal...)

    Vielen Dank..


    .... Bin noch am arbeiten an der Sache... Im Moment funktioniert der Traktor den ich aus dem Serientraktor kopiert habe noch nicht aber das wird schon noch.

    trotzdem eine neue Frage...

    In den Mod Ordnern die man so findet gibt es immer:

    - Traktor.i3d

    - Traktor.i3d.shapes

    - Traktor.xml

    dazu:

    - modDesc.xml

    - icon.dds

    - store_Traktor_dds

    und Ordner:

    - textures

    -lights

    -sounds

    manchmal auch noch ein paar andere Sachen

    Im Serienmäßigen Verzeichnis ist das anders, es gibt keine Ordner (die scheinen dafür in "shared "drin zu sein.

    Aber es gibt alle DDS Texturen einzeln und natürlich die 3 Dateien für den Traktor selbst:

    - Traktor.i3d

    - Traktor.i3d.shapes

    - Traktor.xml

    Was es nicht gibt ist die ModDesc.xml

    Wozu braucht man die ModDesc?

    Die i3D scheint der Traktor zu sein mit der Geometrie drin, die XML.scheint für die Bestimmung der Variablen (Motorvarianten etc) zuständig zu sein. wozu ist aber die .shapes?

    Vielen Dank,

    B

    Edit durch HoFFi:
    Doppelpost zusammengefasst. Bitte die Bearbeiten Funktion - unten rechts im Beitragsfenster zu finden - nutzen, wenn noch keine Antwort auf den letzten Beitrag erstellt wurde.

    Zum Verständnis, wo man diese findet hier ein Bild, die Buttons erscheinen wenn man mit der Maus in diesen Bereich fährt.

    Edited 2 times, last by da-hoffi: Ein Beitrag von B_6789 mit diesem Beitrag zusammengefügt. (May 10, 2021 at 2:13 PM).

  • Die ModDesc.xml braucht man für jeden "nicht auf der Karte festverbauten" Mod. Die beinhaltet dann so Sachen wie:

    - Den Verweis auf die Shopeinträge (was kann man im Shop an Fahrzeugen etc. wo laden.) Können ja in einem Mod mehrere einzelne Objekte sein.

    - Die Versionsnummer

    - Ggf. entsprechende sprachenspezifische Anpassungen (Thema "l10n")

    ...

    Was sonst noch bei Mods in separaten Verzeichnissen zu finden ist, ist im Grunde genommen, dem Modder überlassen. Ist halt mehr der Tatsache geschuldet, eine bessere Übersicht zu haben.

    Wegen der Shapes Datei:

    Wenn Du im Blender eine i3d exportierst, sind sämtliche Flächen, Vertices etc. in der i3d enthalten. Da es sich um eine "Textdatei" handelt, braucht das ganze natürlich Zeit zum laden etc.

    Wenn Du dann im GE die Datei öffnest, siehst Du auch, dass es funktioniert - Du aber eine Warnmeldung beim Öffnen der Datei bekommst. Speicherst Du die i3d dann via "Export" Funktion in "binary i3d" - dann werden diese Informationen über die einzelnen Vertices, Flächen etc. in die gleichnamige Shapes Datei ausgelagert und es gibt dazu nur noch eine Referenz in der i3d selbst. Ist vorrangig aus Performancegründen. Diese Shapes Datei kannst Du dann halt nicht mehr direkt (ausserhalb vom GE) bearbeiten. Wenn Du Dir das mal anschauen willst, nimm einfach einen Würfel, lege ein Material drauf (wie bei einem Mod) und exportiere das ganze aus dem Blender.

    Öffne den Würfel (i3d) im GE und gehe dann ohne Änderung auf "exportieren" und speichere das dann als binary i3d unter einem anderen Namen. Anschließend vergleiche beide i3d Dateien und Du wirst sehen, was an Informationen nicht mehr in der neuen i3d vorhanden ist... das alles ist dann eben in die shapes Datei ausgelagert worden.

  • Ok, das ist es mit der Shapes. Die schreibt mir dann der GE wenn ich das fertig habe. D.h. es wird vom GE die Shapes Datei immer angepasst auf die Änderungen die ich mache (?).

    Eigentlich ist das aber nicht so wichtig, das macht ja GE automatisch oder?

    Schreibt der GE auch die ModDesc?

    Ich habe leider nicht immer Zugriff auf GE, weil es nur unter Windows läuft. D.h. kann ich heute nicht mehr ausprobieren...

  • ... mühsam ernährt sich das Eichhörnchen wie man sagt... aber, es geht voran... Neuer Mod from Game gemacht, Traktor aufgeteilt und wieder eingebaut. Funktioniert tatsächlich bis zu dem Punkt wo ich die Vis durch die neue ersetze dann ist im Spiel der Anlieferplatz blockiert. Scheint irgendwas mit der skalierung der MainVis zu tun zu haben. Wenn wieder Zeit ist wird das auch noch.

    Ein bisschen ein Problem mit Subtil Surfaces aus Blender gibt es auch noch. Wenn ich mehr als 3 Subdivisions auf das Teil mache (damit es rund wird) wird offenbar das file zu groß - GE stürzt ab. Da scheint ein Limit bei irgendwo um 12MB zu sein.

    Sonst, erstmal 10000x Danke an Modelleicher (falls er hier ist) - sehr gut Tutorials auf youtube!

  • Das mit dem Anlieferplatz nervt....

    Wer weiß warum das so ist?

    Soweit geht das alles, ich habe das Modell zerlegt und das Chassis ohen VA und Hydraulik einzeln. Das soll die neue Main-Vis werden.

    Ich kann alles auf unsichtbar stellen und habe dann im Spiel ein fleigendes Chassis - so weit so gut...

    Aber dann...

    Die Originaldatei ist des 900 leider etwas anders organisiert als im Video von Modelleicher der den Fendt500 verwendet hat.

    Es gibt einen vario 900 main component, darunter die Vario 900 vis, darin liegen alle Teile, ausser Collisions und skinned Meshes (Teile vom Sitz)

    Der Plan war, die original Vario900vis durch das Chassis zu ersetzen. Also alle Teile vorher vom orig. Vario_vis in das Chassis zu verschieben, dann original löschen und das chassis umbenennen.

    Das geht schief, Anlieferplatz belegt....

    Was funktioniert ist (Bild 2):

    das Replace Skin Nodes Scipt auszuführen ( die orig Vis wird dann zu eine leeren Transf Group).

    Das neue Chassis (im Bild schon umbenannt, hat aber keine Auswirkungen) ist nun in der vario_900 main components.

    Alles funktioniert ausser den vorderen Kotflügeln (irgendwo verloren gegangen...)

    Wenn ich nun ein Bauteil, egal ob z.B. wheels oder die Kameras aud der originalen vario_900 vis (jetzt transf Group) herausnehme - dann habe ich das Anlieferplatz Problem.

    Es scheint die Position oder Größe der Teile hängt von der Transf Group ab in der sie stecken -

    Die Frage ist, wie kann ich diese Information auf die beue Transf.Grp übertragen??

    Vielen Dank,

    Grüße,

    B

  • Hallo,

    die Meldung, das der Anlieferplatz blockiert ist,

    hat nicht wirklich was mit dem Anlieferplatz zu tun.

    Die Meldung deutet auf einen Zuordnungsfehler zwischen der i3d und der XML hin.

    Das Modell besteht in der i3d aus lauter Nodes. Jede Node hat eine eindeutige Nummer in der Baumhirarchie.

    Wenn Du oberhalb einer bereits existierenden Node etwas einfügst oder löscht,

    verändern sich alle Nodes des entprechenden Baumes, unethalb dieser Node.

    Das bedeutet, daß in der XML alle betroffenen Nodes angepasst werden müssen.

    Beim Löschen ist es daher oft einfacher, eine Dummy-Node stehen zu lassen,

    und das Modell erst ganz am Ende, einmal komplett aufzuräumen.

    Am einfachsten lassen sich solche Fehler in der Log-Datei finden, dort werden unlogische Zuordnungen aufgelistet.

  • Ok, vielen Dank. Das hört sich logisch an. Das Problem trat auf wenn ich die alte Vario900_vis entferne. Wenn ich sie einfach drinlasse und nur unsichtbar schalte funktioniert alles normal. Aber ich wollte es "ordentlich! haben und den Originaltraktor rauslöschen damit ich nicht die Geometrie 2 mal drin habe.

  • Wie schon gesagt,

    es ist das Einfachste, einen Dummy, also eine leere TG, an die Stelle des zu löschenden Objetes zu setzen.

    Das geht ganz einfach mit der replace Funktion.

    Wenn diese leere TG einen auffälligen Namen trägt, erkennt man später leicht, was man beim Aufräumen alles ändern muß.

    Man kann diese Dummies aber auch einfach in dem Mod lassen, denn sie belasten das System und die Dateigröße nicht.

  • WolfIQ

    Da hast du prinzipiell recht, aber wenn ich ehrlich sein darf ist das schon anstrengend wenn man Dummies drin hat, das war teilweise extrem in älteren LS Spielen mit den Mods aus dem osteuropäischen Raum. Die sahen teilweise für die damaligen Verhältnisse optisch super aus, aber wenn man in die I3D geschaut hat, hatte man schon keine Böcke mehr was zu machen weil empfundene 500000 TGs verbaut waren wovon nur 20 eine Funktion hatten. Das war echt abartig. Darum mach ich das für mich persönlich immer so sauber und ordentlich wie möglich, nur die TGs rein die auch benötigt werden. Alles andere ist für hinne rum.

  • Schau mal zum Spaß in die Schneidwerkswagen rein die ich im Modhub habe, vergleich die mal in der I3D. Die sind alle identisch aufgebaut. ^^

    Das war für mich das einfachste. ^^ Einfach einen genommen der schon im Hub drin ist, nur die Vis getauscht und die TGs verschoben wo se hin müssen und jö. ^^

    Was den Anlieferplatz angeht, wird entweder in der XML oder der modDesc ein Eintrag falsch sein. Meistes kommt so was vor bei " Copy & Paste " dass mal ein Teil von einem Eintrag nicht richtig markiert ist, oder der Anfang von einem Tag wie <l10n> doppelt drin ist.