Hanomag Konvertieren

  • Hallo,

    Ich habe versucht einen Hanomag Robust900 aus dem ls17 in den 19er zu holen, allerdings lädt die Map nicht mehr

    sobald der mod drin ist. Da ich mich mit logs und xml´s nicht so gut auskenne wollte ich mal fragen ob einer über die

    Logs und Xmls schauen könnte. Würde mich dehr Freuen.

    Lg Julian

    Ps:die dateien sind im Anhang hinterlegt.

    Files

    • HanomagRobust.xml

      (19.98 kB, downloaded 15 times, last: )
    • log.txt

      (563.82 kB, downloaded 6 times, last: )

    Edited 2 times, last by Julian_1204 ().

  • Ok eigentlich habe ich das Spiel auf dem neuesten Stand aber dann schaue ich Mal was ich machen kann. Vielen dank. Wir kann man man das in den logs ändern?


    Lg


    Habe ausversehen runtergeladene logs benutzt ist mir erst jezt aufgefallen wuste nämlich nicht wo die richtigen logs sind deswegen habe ich irgendwelche runtergeladenen von ganz früher aus den anfangszeiten des ls19 genommen meine richtigen logs hinterleg ich hier in der antwort


    Edit by NAME:BadenBauer

    Doppelpost zusammengefasst. Bitte die Bearbeiten Funktion - unten rechts im Beitragsfenster zu finden - nutzen, wenn noch keine Antwort auf den letzten Beitrag erstellt wurde.

    Zum Verständnis, wo man diese findet hier ein Bild, die Buttons erscheinen wenn man mit der Maus in diesen Bereich fährt.

    Files

    • log.txt

      (5.12 MB, downloaded 18 times, last: )

    Edited 2 times, last by BadenBauer: Ein Beitrag von Julian_1204 mit diesem Beitrag zusammengefügt. ().

  • Julian_1204 , also echt jetzt??:rolleyes::rolleyes: Diese Log ist doch ein Fake, oder??8| Muss ein Fake sein, weil kein normaler Mensch hat über TAUSEND Mods im Ordner.

    Von den fast ACHZEHNTAUSEND Warnings für die Key-Bindings will ich gar nicht erst anfangen....


    Wer einen Mod konvertiert und dann testen will macht diese mit einem LEEREN Modordner auf einer Standartmap

    Eventuell auftretende Rechtschreibfehler sind durchaus beabsichtigt und dienen der Belustigung des geneigten Lesers

  • Nein die logs sind nicht fake lade alle Mods runter die mir gefallen da kommt einiges zusammen.

    Gibt es auch einen anderen weg mods zu testen? Der mod wird ja angezeigt nur die map lädt dann halt nicht

    Obwohl ich eine standart map benutze zum testen

  • wenn man so was macht dann nimmt man nur den einen Mod in den Ordner den man umbauen mag oder was auch immer und testet auf der Standardkarte, da wird die Log viel übersichtlicher nur mal so als Tipp


    ich glaub nicht da hier einer Lust hat so eine Log durch zusuchen denn da sind Fehler drin von etlichen Mods


    und in Zukunft bitte keine Doppelpost sondern die beabeiten Funktion benutzen da für ist sie das :) Danke





    MFG Zetor 6245
    wer Rechtschreibfehler findet darf sie behalten :ugly:

  • So, nun mach mal bitte Deinen ganzen Modsordner leer oder verschiebe ihn auf den Desktop. Danach bitte NUR den "umgebauten" Mod ohne andere in den Ordner.

    Dann ein neues Spiel starten und auch abspeichern. Im Anschluss hier die Log posten.

  • Ok werde ich Mal ausprobieren.

    Lg und vielen Dank für die Hilfe


    Habe jetzt den alten mods ordner mods2 genannt und einen neuen erstellt wo nur der haomag drin ist.

    Die log ist jezt im anhang hinterlegt


    Edit by NAME:BadenBauer

    Doppelpost zusammengefasst. Bitte die Bearbeiten Funktion - unten rechts im Beitragsfenster zu finden - nutzen, wenn noch keine Antwort auf den letzten Beitrag erstellt wurde.

    Zum Verständnis, wo man diese findet hier ein Bild, die Buttons erscheinen wenn man mit der Maus in diesen Bereich fährt.

    Files

    • log.txt

      (509.98 kB, downloaded 7 times, last: )

    Edited 2 times, last by BadenBauer: Ein Beitrag von Julian_1204 mit diesem Beitrag zusammengefügt. ().

  • Quote

    2020-10-16 08:59 Error: Vehicle type 'FS19_HanomagRobust.Robust900' has unknown specialization 'FS19_HanomagRobust.steerable'!

    2020-10-16 08:59 Error: Vehicle type 'FS19_HanomagRobust.Robust900' has unknown specialization 'FS19_HanomagRobust.wheelRotations'!

    2020-10-16 08:59 Error: Not all prerequisites of specialization motorized are fulfilled

    2020-10-16 08:59 Error: Not all prerequisites of specialization drivable are fulfilled

    2020-10-16 08:59 Error: Not all prerequisites of specialization FS19_HanomagRobust.interactiveControl are fulfilled

    Du verwendest wohl noch einen eigenen vehicleType, der nicht mehr unterstützte Specializations und Scripte nutzt.

    Lösung: in der Moddesc die Abschnitte <specializations> und <vehicleTypes> löschen. Falls vorhanden auch <extraSourceFiles>

    In der Hanomag.xml dann ganz oben den type="xxxx" auf "tractor"


    Quote

    2020-10-16 08:59 Error: Failed to open xml file 'C:/Users/Julian/Downloads/Documents/My Games/FarmingSimulator2019/mods/FS19_HanomagRobust/Hanomag.xml'.

    2020-10-16 08:59 Error (C:/Users/Julian/Downloads/Documents/My Games/FarmingSimulator2019/mods/FS19_HanomagRobust/Hanomag.xml): No storeData found. StoreItem will be ignored!

    Das liegt entweder am vorherigen Fehler oder in der Hanomag.xml stimmt die Syntax nicht.

    Um das aber festzustellen, erstmal den ersten Fehler beheben und dann nochmal testen.


    Ich garantiere dir eh, das nach Behebung des Fehlers, viele viele weitere auftauchen werden.

    ...official coffee-to-xml converter...

    ...complaining about other people's log-files since FS13...

    specialized in: textures, ingaming, animations, tutorials and things nobody ever thought about

  • Habe diesen fehler jetzt behoben, die map startet jetzt allerdings wird der Trecker nicht im Shop angezeigt

    Files

    • log.txt

      (30.95 kB, downloaded 4 times, last: )

    Edited once, last by Julian_1204 ().

  • Error: Failed to open xml file 'C:/Users/Julian/Downloads/Documents/My Games/FarmingSimulator2019/mods/FS19_HanomagRobust/Hanomag.xml'


    Pfad anpassen in der moddesc zu der Datei das speil kann diese an der angegben Stellen nicht finden



    Wie war ds mit Doppelpost ??????? weiter oben ?





    MFG Zetor 6245
    wer Rechtschreibfehler findet darf sie behalten :ugly:

  • Nachdem ich es in den Moddesc xmls dateien geändert habe wird der Trecker im Shop angezeigt allerdings "lädt" er nicht d.h. wenn man drauf klickt ist die ganze zeit das

    "lade" zeichen und man kann ihn nicht kaufen, denn wenn man auf kaufen drückt lädt es die ganze zeit und es passiert nichts die neuen logs sind jetzt im ersten post

  • Quote

    Warning: 'HANOMAG' is an unknown brand! Using Lizard instead! (C:/Users/Julian/Downloads/Documents/My Games/FarmingSimulator2019/mods/FS19_Hanomag/HanomagRobust.xml)

    Da "Hanomag" als brand/Marke nicht im Spiel vorhanden ist, muss man diese erst in der moddesc definieren.

    Code
    <brands>
    <brand name="NAME_DEINER_MARKE_IN_GROSSBUCHSTABEN" title="Name deiner Marke so wie er im Shop erscheinen soll" image="Logo_zum_brand.dds"/>
    </brands>



    Quote

    Error: Out-dated custom shader. 'C:/Users/Julian/Downloads/Documents/My Games/FarmingSimulator2019/mods/FS19_Hanomag/shaders/alphanumericsShader.xml' has version 3 . Please convert this file to version 4 .

    Error: Out-dated custom shader. 'C:/Users/Julian/Downloads/Documents/My Games/FarmingSimulator2019/mods/FS19_Hanomag/textures/vehicleShaderDirt.xml' has version 3 . Please convert this file to version 4 .

    Error: Out-dated custom shader. 'C:/Users/Julian/Downloads/Documents/My Games/FarmingSimulator2019/mods/FS19_Hanomag/vehicleShaderDirt.xml' has version 3 . Please convert this file to version 4 .

    Der mod benutzt noch alte shader-Dateien. Da hast du zwei Möglichkeiten:

    a) gucken ob du im LS-Installationsverzeichnis/data/fs17support/shaders einen passenden findest

    b) einen aktuellen Shader aus LS-Installationsverzeichnis/data/shaders nutzen und den gesamten Mod auf das neue Textursystem bringen (PBR/UDIM und specular anpassen)



    Quote


    Warning: Material glass uses unsupported cube reflection map.

    Warning: Material lambert4 uses unsupported cube reflection map.

    Warning: Material ZetorMajor_mat uses unsupported cube reflection map.

    Warning: Material glass uses unsupported cube reflection map.

    Warning: Material stollFrontLoaderFZ_mat uses unsupported cube reflection map.

    cubeMaps werden nicht mehr unterstützt. Sollte aber weggehen, wenn du die i3d einmal neu speicherst.




    Quote


    Warning (C:/Users/Julian/Downloads/Documents/My Games/FarmingSimulator2019/mods/FS19_Hanomag/HanomagRobust.xml): I3D file offers '3' objects, but '1' components have been loaded!

    Wahrscheinlich grad dein kleinstes Problem: im GE darf in erster Ebene im Szenegraph keine Kamera oder Licht sein --> Löschen



    An der Stelle würde ich die Analyse auch einfach mal abbrechen.

    Ganz ohne Eigeninitiative, wird das hier sonst einfach wieder ein Fall von "ich sag dir was du klicken/schreiben musst". Im Grunde kann man es dann auch selbst machen.



    Wenn du selbst wirklich weiter machen willst, würde ich mich nach Beheben der obrigen Fehler, erstmal den "Index not found" Fehlern widmen.

    Da musst du aber halt wirklich mal xml und i3d vergleichen, um rauszufinden, was genau falsch ist.

    ...official coffee-to-xml converter...

    ...complaining about other people's log-files since FS13...

    specialized in: textures, ingaming, animations, tutorials and things nobody ever thought about