Posts by Doomlord1987

    so.. ich habe das jetzt eingetragen...


    self.materials = {};

    self.materials[FillUtil.fillTypeNameToInt["wheat"]] = getMaterial(self.inputMove.movingId2, 0);

    self.materials[FillUtil.fillTypeNameToInt["barley"]] = getMaterial(self.inputMove.movingId2, 1);

    self.materials[FillUtil.fillTypeNameToInt["rape"]] = getMaterial(self.inputMove.movingId2, 2);

    self.materials[FillUtil.fillTypeNameToInt["sunflower"]] = getMaterial(self.inputMove.movingId2, 4);

    self.materials[FillUtil.fillTypeNameToInt["soybean"]] = getMaterial(self.inputMove.movingId2, 5);

    self.materials[FillUtil.fillTypeNameToInt["maize"]] = getMaterial(self.inputMove.movingId2, 3);

    self.materials[FillUtil.fillTypeNameToInt["oat"]] = getMaterial(self.inputMove.movingId2, 6);

    self.materials[FillUtil.fillTypeNameToInt["rye"]] = getMaterial(self.inputMove.movingId2, 7);

    self.materials[FillUtil.fillTypeNameToInt["spelt"]] = getMaterial(self.inputMove.movingId2, 8);

    self.materials[FillUtil.fillTypeNameToInt["lime"]] = getMaterial(self.inputMove.movingId2, 9);

    self.materials[FillUtil.fillTypeNameToInt["compost"]] = getMaterial(self.inputMove.movingId2, 10);

    self.materials[FillUtil.fillTypeNameToInt["pigFood"]] = getMaterial(self.inputMove.movingId2, 11);

    self.materials[FillUtil.fillTypeNameToInt["straw"]] = getMaterial(self.inputMove.movingId2, 12);

    self.materials[FillUtil.fillTypeNameToInt["grass_windrow"]] = getMaterial(self.inputMove.movingId2, 13);

    self.materials[FillUtil.fillTypeNameToInt["dryGrass_windrow"]] = getMaterial(self.inputMove.movingId2, 14);




    Werde das jetzt mal testen und mich dann noch einmal zu wort melden..




    LG

    Hi... emm also...


    Silo 1 ( Standart verbaut )

    <UserAttribute nodeId="31427">

    <Attribute name="addNumberToName" type="boolean" value="true"/>

    <Attribute name="capacity" type="integer" value="200000"/>

    <Attribute name="displayIndex" type="string" value="2"/>

    <Attribute name="doorIndex" type="string" value="7"/>

    <Attribute name="fillTypes" type="string" value="wheat rape barley maize sunflower soybean"/>

    <Attribute name="inputIndex" type="string" value="0"/>

    <Attribute name="lightIndex" type="string" value="4"/>

    <Attribute name="onCreate" type="scriptCallback" value="modOnCreate.FarmSiloSystem"/>

    <Attribute name="outputIndex" type="string" value="1"/>

    <Attribute name="playerTriggerIndex" type="string" value="6"/>

    <Attribute name="saveId" type="string" value="FarmSiloSystem1"/>

    <Attribute name="soundIndex" type="string" value="5"/>

    <Attribute name="stationName" type="string" value="Hofsilo"/>

    <Attribute name="switcherIndex" type="string" value="3"/>

    </UserAttribute>



    Silo 2 ( Standart verbaut )

    <UserAttribute nodeId="31554">

    <Attribute name="addNumberToName" type="boolean" value="true"/>

    <Attribute name="capacity" type="integer" value="200000"/>

    <Attribute name="displayIndex" type="string" value="2"/>

    <Attribute name="doorIndex" type="string" value="7"/>

    <Attribute name="fillTypes" type="string" value="oat rye spelt lime compost pigFood"/>

    <Attribute name="inputIndex" type="string" value="0"/>

    <Attribute name="lightIndex" type="string" value="4"/>

    <Attribute name="onCreate" type="scriptCallback" value="modOnCreate.FarmSiloSystem"/>

    <Attribute name="outputIndex" type="string" value="1"/>

    <Attribute name="playerTriggerIndex" type="string" value="6"/>

    <Attribute name="saveId" type="string" value="FarmSiloSystem2"/>

    <Attribute name="soundIndex" type="string" value="5"/>

    <Attribute name="stationName" type="string" value="Hofsilo"/>

    <Attribute name="switcherIndex" type="string" value="3"/>

    </UserAttribute>


    Silo 3 ( Neu dazu gekommen )

    <UserAttribute nodeId="50450">

    <Attribute name="addNumberToName" type="boolean" value="true"/>

    <Attribute name="capacity" type="integer" value="200000"/>

    <Attribute name="displayIndex" type="string" value="2"/>

    <Attribute name="doorIndex" type="string" value="7"/>

    <Attribute name="fillTypes" type="string" value="straw grass_windrow dryGrass_windrow"/>

    <Attribute name="inputIndex" type="string" value="0"/>

    <Attribute name="lightIndex" type="string" value="4"/>

    <Attribute name="onCreate" type="scriptCallback" value="modOnCreate.FarmSiloSystem"/>

    <Attribute name="outputIndex" type="string" value="1"/>

    <Attribute name="playerTriggerIndex" type="string" value="6"/>

    <Attribute name="saveId" type="string" value="FarmSiloSystem3"/>

    <Attribute name="soundIndex" type="string" value="5"/>

    <Attribute name="stationName" type="string" value="Hofsilo"/>

    <Attribute name="switcherIndex" type="string" value="3"/>

    </UserAttribute>


    Denke das stimmt soweit. Wenn ich mich nicht irre....



    Wo muss ich die Texturen anpassen?

    Hi,

    es ist schon ein vorhandenes Silo auf der Map.

    Ich habe es einfach kopiert und soweit alles angepasst das ich das was ich dort Lagern will abkippen kann.

    FillTypes eingetragen usw.


    Ich habe es jetzt noch einmal anders probiert, ich habe das komplette Silo Extrahiert, umgearbeitet und dann wieder Inportiert.

    Nun hat das soweit alles gut geklappt, er hat die dds Datei auch genommen und es wird auch ingame angezeigt.


    Es kommt nun aber lua fehler... ( sporadisch )

    ich Poste gleich ein Bild.

    Da ich gerade nicht den fehler bekomme



    LG

    Der "Fehler" kommt wenn ich was Abkippe...

    Hallo Leute..

    ich weiß nicht ob ich gerade aufm Schlauch stehe oder einfach nur zu doof bin.

    Ich spiele derzeit die Klingenbach und habe mir ein weiteres Silo in die Halle gestellt per GE.

    Ich habe alles so umgeschrieben das ich dort Stroh usw einlagern kann, nun möchte ich den Hintergrung beim Schaltkasten änern.

    Habe mir da eine neue Datei erstellt (DDS) mit Sysmbolen usw. benannt und alles eingetragen usw.

    Nun suche ich seid 2 Tagten, aber er nimmt diese Datei nicht, das einzige was er als Error anzeigt ist was mit Doppelte ID, das ist auch mein Problem denk ich.

    Ich habe das vorher alles beim plazierbarem Objekt probiert. Dort hat das alles gut geklappt.



    Im Anhang sind drei Bilder..


    Warscheinlich ist die Lösung nicht dramatisch aber ich steh aufm Schlauch.

    Hoffe ihr könnt mir helfen bzw Tips um auf die Lösung zu kommen.