GE Scenegraph lange Ladezeit.

  • LS17
  • Giants Editor
  • GE Scenegraph lange Ladezeit.

    Guten Tag zusammen.

    Ich habe da ein kleines Problem mit dem GE. Ich habe Anfang des Jahres schon an einer Map gebastelt. Zu der Zeit auf meinem Laptop Lenovo z710 mit i5 CPU 8gb RAM gtx840m gpu und normaler HDD. Da gab es auch keine Probleme.

    Seit 2 Monaten besitze ich nun einen neuen Stand PC CPU ist ein ryzen 5 1600 mit 16gb RAM und ner gtx 1060 6gb gpu. Als Festplatte kommt eine SSD zum einsatz.
    Soviel erstmal zum Technischen stand.

    Jetzt ist es auf meinem Neuen System so das der GE ganz normal Startet aber sobald ich etwas im Scenegraph auswähle lädt er gefühlte 30 bis 60 Sekunden bis ich dann mit dem GE arbeiten kann. Diese ladezeit habe ich jedes mal wenn ich wieder eine andere transform Gruppe auswähle.
    Boden und Fruchtexturen lassen sich ohne Verzögerung zeichnen und auch das ausgewählte Objekt kann ich ohne Probleme verschieben.

    Wie ihr euch sicher denken könnte ist es so fast unmöglich eine map zu ersteölen bzw zu bearbeiten.
    Diese ladezeit besteht allerdings auch nur bei Maps.
    Fahrzeuge und Geräte kann ich problemlos editieren ohne das ich auf den GE Warzen muss.

    Meine Frage wäre nun hat von euch auch jemand solche Probleme oder hatte sie mal und kennt einen Lösungsansatz?
    CPU, RAM und GPU sind wären der Nutzung des GEs nicht wirklich ausgelastet und langweilen sich schon fast. Was mich noch mehr verwundert.

    Bin für jeden Tipp dankbar.

    LG
    Pandory

    PS: sorry für den langen Text.
  • Hallo,

    die Editor.log findest du hier.

    C:\Users\DeinName\AppData\Local\GIANTS Editor 64bit 7.1.0

    Falls der Ordner AppData nicht sichtbar ist musst du ihn über die "Ordner und Suchoptionen änder.." sichtbar machen
    Dateien
    • Unbenannt.JPG

      (41,1 kB, 1 mal heruntergeladen, zuletzt: )
    • 1.JPG

      (88,58 kB, 1 mal heruntergeladen, zuletzt: )


    LS ist meine Religion und

    Modding-Welt meine Kirche.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von BadenBauer ()

  • @BadenBauer Danke für die Info. Datei erfolgreich gefunden. Kleiner Tipp mit %appdata% in der Adressleiste landet man auch ruck zuck im AppData Ordner.

    Hier mal die editor_log.txt direkt nach dem start
    Spoiler anzeigen
    GIANTS Engine Runtime 7.0.0 (14455) 64bit (Build Date: Apr 10 2017)
    Copyright (c) 2008-2016, GIANTS Software GmbH (giants-software.com), All Rights Reserved.
    Copyright (c) 2003-2016, Christian Ammann and Stefan Geiger, All Rights Reserved.
    Application: GIANTS Editor 64bit 7.1.0
    Main System
    CPU: AMD Ryzen 5 1600 Six-Core Processor
    Memory: 16320 MB
    OS: Windows NT 10.0 64-bit
    Physics System
    Version: 5.9.5
    Thread(s): 2
    Sound System
    Driver: OpenAL Software
    Render System
    Driver: OpenGL
    Card Vendor: NVIDIA Corporation
    Renderer: GeForce GTX 1060 6GB/PCIe/SSE2
    Version: 4.5.0 NVIDIA 385.69
    Shader Version: 4.50 NVIDIA
    Max. Texture Layers: 16
    GL_AMD_depth_clamp_separate not supported
    Started 6 threads for threadpool 'Render threadpool'
    Hardware Profile
    Level: Very High (forced)
    View Distance Factor: 1.300000
    Shadow Quality: 2.000000 Size: 4096 Filter-Size: 16
    Shader Quality: 3
    Skip Mipmaps: 0
    LOD Distance Factor: 1.300000
    Terrain LOD Distance Factor: 2.000000
    Terrain Normal Mapping: Yes
    Foliage View Distance Factor: 1.600000
    Foliage Density: 0.500000
    Volume Mesh Tessellation Factor: 0.750000
    Tyre Tracks Segments Factor: 4.000000
    Max. Number of Shadow Lights: 5
    Max. Number of Lights: 512
    Max. Number of Lights Per Cluster: 32
    MSAA: 4
    Check for updates (GDN {GIANTS Developer Network})
    C:\Users\XXX\Documents\My Games\FarmingSimulator2017\mods\HofBergmann\FS17_HofBergmann\maps\map01.i3d (3207.48) ms


    Auslastungen beim Anklicken einer Transformgroup im Scenegraph
    CPU 11%
    RAM 49%
    GPU Kern 2% Vram 41%

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von pandory ()

  • pandory schrieb:

    Kleiner Tipp mit %appdata% in der Adressleiste landet man auch ruck zuck im AppData Ordner.
    Das wusste ich, aber wenn der Ordner dauerhaft sichtbar ist, ist es einfacher dahin zu gelangen als wenn man immer den Befehl eingeben muss. ;)

    Auf anhieb kann ich da jetzt nichts erkennen, ausser das die Map in einem zusätzlichen Ordner drin ist.

    Normalerweise sollt die Map direkt nach "\Mods" kommen und nicht wie bei dir "\Mods\HofBergmann\FS17_HofBergmann\maps\map.i3d"

    Ob das aber jetzt ausschlaggebend ist weiß ich leider nicht.


    LS ist meine Religion und

    Modding-Welt meine Kirche.
  • Mein Mapsordner ist anders Strukturiert. Hab dort 2 Ordner einen für meine Aktuell bespielte Map und einen Mit meiner Bastelmap. Pfad ist dem LS ja egal so lange er ind er Config angegeben ist. Aber denke dem GE sollte es egal sein wo eine i3d geöffnet wird. Normal habe ich Sachen die in Bearbeitung sind eh auf der 2. SSD