Hilfe beim ersetzen im GiantsEditor (Ponsse Buffalo mit Seilwinde)

  • LS17
  • Hilfe beim ersetzen im GiantsEditor (Ponsse Buffalo mit Seilwinde)

    Wunderschönen guten Abend,

    nach einer Ewigkeit melde ich mich mal wieder zurück, hatte irgendwie mal den Spaß an LS und auch am modden verloren.

    Natürlich melde ich mich gleich mit einem Problem zurück ;) Ich baue mir gerade einen Ponsee Buffalo um, ich habe den Rungenkorb etwas verändert, bzw. etwas kleiner gemacht und das Stirngitter ein Stück nach hinten verschoben, dass dann eine Winde drauf passt. Leider habe ich das Problem dass der GE nach dem import und anschließendem Replace abstürzt und sich die "neue" i3d nicht mehr öffnen lässt.

    Ich schildere euch mal wie ich vorgegangen bin (und zwar locker schon 30mal):

    - Ich habe die "backPart_vis" exportiert und in Blender bearbeitet
    - In Blender alle Texturpfade angepasst, gespeichert und als i3d exportiert. (Lässt sich fehlerfrei im GE öffnen und bearbeiten)
    - Giants Editor geöffnet > "New Mod from Game" > Buffalo ausgewählt > gespeichert
    - Ordner geöffnet, die bearbeitete i3d der "backPart_vis" eingefügt
    - ponsseBuffalo.i3d geöffnet > TG backPart_vis kopiert > in das Rootverzeichnis eingefügt
    - Bearbeitet backPart_vis importiert > unnötige Kamera und Lampe gelöscht
    - Bei der bearbeiteten backPart_vis "Freeze Transformation" mit Translate, Rotate und Preserve Instances eingestellt, apply gedrückt (sonst verdreht es mir alles was ich reinkopiere)
    - Aus der originalen TG "backPart_vis" die children rauskopiert > in bearbeitete backPart_vis eingefügt
    - In der Console folgender Fehler: "Warning: Skinned shape cloning failed. Not all transforms have been cloned 'pipeArm01'." (Sind die Schläuche von der Kabine zum Kran)
    - Kopierte backPart_vis gelöscht
    - Zur originalen backPart_vis, Create>Replace, bearbeitete backPart_vis reingeladen
    - Übrige backPart_vis gelöscht
    - Rigid Body deaktiviert
    - Gespeichert
    - GE geschlossen
    - ponsseBuffalo.i3d öffnen > GE stürzt ab

    Jetzt weiß ich nicht mehr weiter, ich denke es hängt irgendwie mit den Schläuchen zusammen, aber egal was und wie ich es versucht hab, immer schmiert der GE ab. Selbst wenn ich die skinnedNodes rauslösche. Wenn ich das ganze dann trotzdem in eine zip packe und ins Spiel bringe, Stürzt der LS auch ab.

    Grüße

    der lang verschollene Olli :Tach:
    May the Forst be with you!
  • ich kann hier leider nur spekulieren aber mit LS17 haben ja die "Bones" Einzug in die Modelle gehalten und da war das mit mal eben exportieren, ändern, importieren...nicht so einfach.

    Glaub aber dazu können hier andere was genaueres sagen.
    ...wandelt Kaffee in xml's um...

    Spezialisiert auf: Texturen, Ingaming, Animationen, Tutorials und Dinge an die noch keiner zuvor gedacht hat

  • Was ich aber nicht so ganz verstehe, wenn ich die doch lösche, auch die einträge, müsste es ja eigentlich funktionieren, oder?

    Abgesehen davon, die Schläuche gehen ja von der Kabine zum Kran, an dem hab ich nichts verändert und sie sind im GE auch an der exakt selben position?! Ich hab den ganzen Sonntag damit verbracht, aber ohne Erfolg :uglyspitze:

    Treibt mich in den Wahnsinn :D

    P.S.: Wenn ich statt sie zu kopieren, sie ausschneide und einfüge, kommt der selbe Fehler
    May the Forst be with you!
  • Mir kam jetzt da noch eine Idee, brauche da aber erstmal Rat ob das überhaupt funktioniert:

    Könnte man die TG bzw. die Children in der i3d per Notepad++ an die richtige stelle bewegen?

    Also beispielsweise ich nehme die Children, schneide sie aus und füge sie ins Rootverzeichnis, dann die 2 bodyPart_vis miteinander replacen, speichern, i3d mit Notepad öffnen und dann die Pfade per Hand anpassen?

    Wäre schön dazu mal eine Meinung zu hören ;)

    Grüße
    May the Forst be with you!