Allgemeine Informationen zum Mapbau

  • LS17

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • @da-hoffi vielen Dank =) die kommt doch schon mal sehr sehr gut. Ich schaue heute Abend mal wie die im GE und Ingame ausieht. :thumbup:

    @waschtl ach du, n bisl kaputt und abgefahren kann die ruhig sein =) aaaaaber, wenn du Bock und Zeit hast was zur "Am Landgrabental" beizutragen, möchte ich dich nicht aufhalten wenn du die Texe noch optimieren möchtest :ugly: :zuviel:
  • Das war nur schnell zusammengefricket, mit dem was ich grad auf google an Texturen gefunden hab.
    Optimieren geht da immer. Brauch dann nur genaue Hinweise
    ...wandelt Kaffee in xml's um...

    Spezialisiert auf: Texturen, Ingaming, Animationen, Tutorials und Dinge an die noch keiner zuvor gedacht hat

  • Echt? 8o das wäre der Hammer, ich fahre den Plattenweg den ich brauch gleich lang, dann mach ich mal ein Bild davon ^^

    Und Daniel, hab gerade deinen Map-Thread mal durchgeblättert - erstmal ----> :thumbup: top, gefällt. Ich sehe, was mappen angeht sind wir beide ziemlich Detailverliebt. Bei mir muss das auch alles so realistisch wie möglich sein.


    Da hab ich so ein kleines, nettes Fachwerkhaus gesehen. Wo haste dit her ? :search:
  • was die Straße angeht, wenn du das machen kannst einmal schön von oben.
    Eine Platte und einmal das Zwischenzeug dann sollte das Ergebnis passen.

    Was das haus angeht schick mal link. Vermute aber das ist n 13er Modell....https://www.modhoster.de/mods/friseur
    ...wandelt Kaffee in xml's um...

    Spezialisiert auf: Texturen, Ingaming, Animationen, Tutorials und Dinge an die noch keiner zuvor gedacht hat

  • DecanKane schrieb:

    Schade, dass bisher keiner ne Idee zu dem zweiten Problem hat.... das ist echt besch..... muss sonnst vons ehr weit vorn anfangen...
    Aber naja..

    Zu dem Problem mit dem Tor @PapaBear

    In den UserAttributes fehlen Einträge, sodass sie funktionieren, und das bei so ziemlich jedem Tor des Modders.
    Und zwar fehlt einmal das Atribute ScriptCallback "onCreate"- AnimatedObject.onCreate und beim Pfad zur AnimatedObjects.xml musste ich anpassen, da bei mir die xml im "maps-Ordner" liegt.
    Siehe Bilder.
    Hoffe das ist verständlich.



    Ich hoffe jemand aht zu dem Problem mit der verschwundenen tipCol ne Offenbarung 8|
    danke DecanKane
    diese Erklärung hat mir sehr geholfen jetzt gehen endlich meine tore
  • Nun eine Möglichkeit die mir Farmer Andy ans Herz geleckt hat erstelle eine Wasserplan unter der Map mit dem oncreate wert. Dann ist die Warnung verschwunden Problem nur das du dann auch in Teiche fahren kannst ohne Warnung. Nicht mal Giants hat das 100% hinbekommen, ich weis nicht ob es immer noch so ist aber früher konnte man auf der Goldcrest Valey wenn man in seine Garage gefahren ist die Warnung lesen.
  • @da-hoffi danke, hat funktioniert!

    Hab n paar Fehler entdeckt beim testen.
    Spoiler anzeigen

    Error: Adding onCreate loaded object with duplicate saveId BunkerSilo_Silo1
    Error: Adding onCreate loaded object with duplicate saveId BunkerSilo_Silo2
    Error: Adding onCreate loaded object with duplicate saveId BunkerSilo_Silo1
    Error: Adding onCreate loaded object with duplicate saveId BunkerSilo_Silo2
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_light03
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Door
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Gate1
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Gate2
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Gate3
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Gate4
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_LightsInside
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Rotoren
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate


    Hab mit Absicht nur die Fehler aus der "LOG" raus kopiert, alles andere ist sauber.
    Wie kommen die Zustande? Weil ich die Objekte einfach per STRG+D dupliziert habe? :search:
    Jemand da n Plänchen? ^^
  • DecanKane schrieb:

    @da-hoffi danke, hat funktioniert!

    Hab n paar Fehler entdeckt beim testen.
    Spoiler anzeigen

    Error: Adding onCreate loaded object with duplicate saveId BunkerSilo_Silo1(gleicher Name A)
    Error: Adding onCreate loaded object with duplicate saveId BunkerSilo_Silo2(gleicher Name B)
    Error: Adding onCreate loaded object with duplicate saveId BunkerSilo_Silo1(gleicher Name A)
    Error: Adding onCreate loaded object with duplicate saveId BunkerSilo_Silo2(gleicher Name B)
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate( gN C)
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate(gN C)
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_light03
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Door
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Gate1
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Gate2
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Gate3
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Gate4
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_LightsInside
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_Rotoren
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate
    Error: Adding onCreate loaded object with duplicate saveId AnimatedObject_visable_gate


    Hab mit Absicht nur die Fehler aus der "LOG" raus kopiert, alles andere ist sauber.
    Wie kommen die Zustande? Weil ich die Objekte einfach per STRG+D dupliziert habe? :search:
    Jemand da n Plänchen? ^^

    Hab dir nun 3 beispiele Markiert mit A,B,C du kannst keine gleichen SaveID haben. Musst mal schauen ob die sachen eine SaveId in den user attributen haben oder wenn nicht umbennen anfangen. Zum Beispiel Bunker Silo 1, Bunker Silo 2, Bunker Silo 3 usw.
  • Neu

    Danke! Fehler ist behoben.

    Hab da noch einen:
    Spoiler anzeigen

    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.


    Kann den iwie nich ganz nachvollziehen.... Sound-Datei ist im Ordner, in der animatedObjects.xml ist der Pfad maps/sounds für die jeweiligen Lichtschalter angegeben, komischer Weise versucht er hier die Sounddatei gleich direkt aus dem Ordner "sounds" zu laden, da liegt der Ordner aber nicht. Wo kann man diese Pfade anpassen? Geht das auch im GE? Denke da liegt der Fehler irgendwo.... :search:
  • Neu

    DecanKane schrieb:

    Danke! Fehler ist behoben.

    Hab da noch einen:
    Spoiler anzeigen

    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load resource 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.
    Error: Can't load sample 'C:/Users/Tino/Documents/My Games/FarmingSimulator2017/mods/FS17_Am_Landgrabental/sounds/switch01_0.wav'.


    Kann den iwie nich ganz nachvollziehen.... Sound-Datei ist im Ordner, in der animatedObjects.xml ist der Pfad maps/sounds für die jeweiligen Lichtschalter angegeben, komischer Weise versucht er hier die Sounddatei gleich direkt aus dem Ordner "sounds" zu laden, da liegt der Ordner aber nicht. Wo kann man diese Pfade anpassen? Geht das auch im GE? Denke da liegt der Fehler irgendwo.... :search:
    Nun das deine Sounds da nicht sind ist schon einmal ein Problem. Der übersichthalber und um die Map groese klein zu halten sollten die alle in diesem Ordner kommen. Nun aber zum ändern wenn du das aus welchen gründen auch immer nicht willst. Du kannst denn Sound in der AnimatedObjects.xml anpassen, vermute ich jetzt einfach mal da es eine switch ist wirst du auch eine Zeile in der animatedobjects dazu haben. da gibt es dann die Unterzeile für Sound und da kannst du die Ordner Struktur anpassen.
  • Neu

    Die Sounds sind ja da, nur versucht das Spiel die Dateien irgendwie über einen anderen Pfad zu laden.
    Siehe Bilder:



    Die Dateien für die Sounds sind da, die Tore haben auch Ingame Sound beim öffnen. Nur halt die Lichtschalter nicht, da er da versucht über einen anderen Pfad zu laden, welcher nicht einmal in der AnimatedObjects.xml angegeben ist.


    Bin gerade überfragt ?(
  • Neu

    DecanKane schrieb:

    Nur halt die Lichtschalter nicht, da er da versucht über einen anderen Pfad zu laden, welcher nicht einmal in der AnimatedObjects.xml angegeben ist.
    Hast du schon mal versucht über Notepad++ in Dateien zu suchen?

    np++_search_in_files_example_screen.jpg

    Du kannst dabei ja alle möglichen Dateitypen hinzufügen um eben mehrere Dateien auf einmal zu durchsuchen, und nach "FS17_Am_Landgrabental/sounds/switch01_0.wav" oder vielleicht auch noch nur nach dem Ordnerpfad, "FS17_Am_Landgrabental/sounds/" falls irgendwo in einen Attribut ein anderer Pfad festgelegt wurde.